summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-12-12 17:53:16 +0000
committerXavier Claessens <xclaesse@src.gnome.org>2007-12-12 17:53:16 +0000
commitc15466cbbd83a69ac733fb5645f9c5df815d9250 (patch)
treea915c500473893e501a0e1c1b64f536d46f2ad21 /Makefile.am
parent02f27e70cf032fb8b5879e49148e192cb9fe688b (diff)
downloadtelepathy-account-widgets-c15466cbbd83a69ac733fb5645f9c5df815d9250.tar.gz
Generate ChangeLog from svn commits. Copy generator from epiphany
svn path=/trunk/; revision=474
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e33ab363..374608ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,18 @@ DISTCLEANFILES = \
# uninstall.
distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
-dist-hook:
- chmod a+w ${distdir}/ChangeLog
- if test -d _darcs; then darcs changes >${distdir}/ChangeLog; fi
+# Build ChangeLog from SVN history (r470 was the first ChangeLog-less checkin).
+# Only build this when in an svn checkout.
+
+ChangeLog:
+ @if test -f $(top_srcdir)/.svn/entries; then \
+ svn log -v --xml -r HEAD:470 $(SVN_ROOT)/$(SVN_MODULE) | \
+ xsltproc --stringparam strip-prefix "$(SVN_MODULE)/$(SVN_BRANCH)" \
+ --stringparam include-rev "yes" $(top_srcdir)/svn2cl.xsl - > $@; \
+ fi
+ @cat $(top_srcdir)/ChangeLog.old >> $@
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+