summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Barisione <marco.barisione@collabora.co.uk>2013-08-01 15:37:28 +0100
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-20 11:44:24 +0100
commit0aab6f2536812fad6ca357d199b48b261d0041b6 (patch)
treeaa143af3bc8b6f87410d3da0060f8bf19db3e7f4 /configure.ac
parent4a717c1b59e32e88eae5b17dc4d79d110964e23d (diff)
downloadtelepathy-account-widgets-0aab6f2536812fad6ca357d199b48b261d0041b6.tar.gz
configure.ac: allow to overwrite where to install data files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 587bba7d..bdb7d27a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,6 +125,22 @@ fi
AC_SUBST(LDFLAGS)
# -----------------------------------------------------------
+# Allow to overwrite where to install icons and other data
+# files
+# -----------------------------------------------------------
+AC_ARG_WITH([pkgdatadir],
+ AS_HELP_STRING([--with-pkgdatadir],
+ [set a different directory where to install the icon]),,
+ with_pkgdatadir=)
+
+if test x"$with_pkgdatadir" != x"" ; then
+ real_pkgdatadir="${with_pkgdatadir}"
+else
+ real_pkgdatadir="${datarootdir}/${PACKAGE_NAME}"
+fi
+AC_SUBST(real_pkgdatadir)
+
+# -----------------------------------------------------------
# Pkg-Config dependency checks
# -----------------------------------------------------------
@@ -327,6 +343,7 @@ Configure summary:
Compiler Flags..............: ${CFLAGS} ${ERROR_CFLAGS}
Linker Flags................: ${LDFLAGS}
Prefix......................: ${prefix}
+ Data directory .............: ${real_pkgdatadir}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
Unreleased version checks...: ${enable_unreleased_checks}