summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-11-29 15:48:27 +0100
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-11-29 15:49:06 +0100
commit317cd9e4b501bb495e69912bf99398fdb0f0cf0b (patch)
tree927ebb1f8c81463f049565d417602889cf44e387 /configure.ac
parentc8655024da08f5a9c4b2e8e6c811fe5c2d13277e (diff)
downloadtelepathy-account-widgets-317cd9e4b501bb495e69912bf99398fdb0f0cf0b.tar.gz
pc: add gudev and cheese as Requires if needed
https://bugzilla.gnome.org/show_bug.cgi?id=710919
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4662e6d8..7a5b070d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,6 +256,13 @@ $UDEV_PKG_ERRORS])
fi
AM_CONDITIONAL(HAVE_UDEV, test "x$have_gudev" = "xyes")
+if test x${have_gudev} = x"yes" ; then
+ REQUIRE_UDEV=", gudev-1.0"
+else
+ REQUIRE_UDEV=""
+fi
+AC_SUBST(REQUIRE_UDEV)
+
# -----------------------------------------------------------
# Cheese (optional dependency for avatar selection)
# -----------------------------------------------------------
@@ -279,6 +286,13 @@ else
fi
AM_CONDITIONAL(BUILD_CHEESE, test x${have_cheese} = xyes)
+if test x${have_cheese} = x"yes" ; then
+ REQUIRE_CHEESE=", cheese-gtk"
+else
+ REQUIRE_CHEESE=""
+fi
+AC_SUBST(REQUIRE_CHEESE)
+
# -----------------------------------------------------------
# ubuntu-online-accounts support
# -----------------------------------------------------------