summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Barisione <marco.barisione@collabora.co.uk>2013-08-22 11:22:50 +0100
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-22 12:52:59 +0100
commit84d26bd9c0301340e1a07bec29a139912e959b32 (patch)
tree1f58ef876a04b1504d47128916723ca1cb49e032 /configure.ac
parent1187b5dae610cdde293d4e67c59b56cdf0d0e956 (diff)
downloadtelepathy-account-widgets-84d26bd9c0301340e1a07bec29a139912e959b32.tar.gz
configure.ac: add --with-gettext-package to avoid conflicts
telepathy-account-widgets is a submodule, so it can be included by multiple projects. If we don't have a different per-project GETTEXT_PACKAGE we end up with different projects shipping .mo files supposed to be installed in the same location.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e07f46d3..671dbfa3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,7 +188,16 @@ fi
# -----------------------------------------------------------
IT_PROG_INTLTOOL([0.50.0])
-GETTEXT_PACKAGE=tpaw
+AC_ARG_WITH([gettext-package],
+ AS_HELP_STRING([--with-gettext-package],
+ [set a different GETTEXT_PACKAGE to avoid conflicts]),,
+ with_gettext_package=)
+
+if test -n "$with_gettext_package"; then
+ GETTEXT_PACKAGE="$with_gettext_package"
+else
+ GETTEXT_PACKAGE=tpaw
+fi
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
@@ -351,6 +360,7 @@ Configure summary:
Data directory .............: ${real_pkgdatadir}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
Unreleased version checks...: ${enable_unreleased_checks}
+ GETTEXT_PACKAGE.............: ${GETTEXT_PACKAGE}
Features:
Cheese webcam support ......: ${have_cheese}