summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Barisione <marco.barisione@collabora.co.uk>2013-08-27 07:49:12 +0100
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-27 15:41:40 +0100
commitd445cc2ace4729dd70bf25628aceb119415dffdf (patch)
treec8bad3ba4625492e401dad9a1b7451c339e0b16f /configure.ac
parentcb1222d2687e4e86bad1dfd72299512d35c0cb7a (diff)
downloadtelepathy-account-widgets-d445cc2ace4729dd70bf25628aceb119415dffdf.tar.gz
build: add --disable-settings to avoid installing the GSettings schema
This is needed to avoid multiple components shipping the same schema. It's just a temporary workaround that won't be needed when https://bugzilla.gnome.org/show_bug.cgi?id=706317 will be fixed. https://bugzilla.gnome.org/show_bug.cgi?id=706801
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82f5e6f1..f928fec5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,23 @@ fi
AC_SUBST(icondir)
# -----------------------------------------------------------
+# Disable the installation of tp-aw's GSettings schema.
+# This can be needed to avoid multiple components shipping
+# the same schema.
+# See https://bugzilla.gnome.org/show_bug.cgi?id=706801
+# -----------------------------------------------------------
+AC_ARG_ENABLE(settings,
+ AS_HELP_STRING([--disable-settings],
+ [compile without installing GSettings schema]),
+ enable_settings=$enableval, enable_settings=yes )
+
+if test x$enable_settings = xyes; then
+ AC_DEFINE(ENABLE_SETTINGS, [], [Enable GSettings schema])
+fi
+
+AM_CONDITIONAL(ENABLE_SETTINGS, test "x$enable_settings" = "xyes")
+
+# -----------------------------------------------------------
# Pkg-Config dependency checks
# -----------------------------------------------------------
@@ -370,6 +387,7 @@ Configure summary:
Prefix......................: ${prefix}
Data directory .............: ${real_pkgdatadir}
Icon directory .............: ${icondir}
+ GSettings schema support....: ${enable_settings}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
Unreleased version checks...: ${enable_unreleased_checks}
GETTEXT_PACKAGE.............: ${GETTEXT_PACKAGE}