summaryrefslogtreecommitdiff
path: root/tp-account-widgets/Makefile.am
diff options
context:
space:
mode:
authorMarco Barisione <marco.barisione@collabora.co.uk>2013-07-26 10:44:30 +0100
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-20 11:03:05 +0100
commitc689cd6a91cb2a31ce0d03f47e59ca4e3f368e9c (patch)
tree8d73e187743964fce43daeee6b3483abd88ab392 /tp-account-widgets/Makefile.am
parent2d72679026f5f39eeffa10e474bcf151ca2002db (diff)
downloadtelepathy-account-widgets-c689cd6a91cb2a31ce0d03f47e59ca4e3f368e9c.tar.gz
uoa-utils: move from Empathy to tp-aw
https://bugzilla.gnome.org/show_bug.cgi?id=699492
Diffstat (limited to 'tp-account-widgets/Makefile.am')
-rw-r--r--tp-account-widgets/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/tp-account-widgets/Makefile.am b/tp-account-widgets/Makefile.am
index dbfffeeb..80089458 100644
--- a/tp-account-widgets/Makefile.am
+++ b/tp-account-widgets/Makefile.am
@@ -63,6 +63,19 @@ libtp_account_widgets_la_SOURCES = \
$(libtp_account_widgets_headers) \
$(NULL)
+# these are sources that depend on Ubuntu Online Accounts
+uoa_sources = \
+ tpaw-uoa-utils.c \
+ tpaw-uoa-utils.h \
+ $(NULL)
+
+if HAVE_UOA
+libtp_account_widgets_la_SOURCES += $(uoa_sources)
+EXTRA_DIST =
+else
+EXTRA_DIST = $(uoa_sources)
+endif
+
# do not distribute generated files
nodist_libtp_account_widgets_la_SOURCES = \
$(BUILT_SOURCES)
@@ -70,6 +83,7 @@ nodist_libtp_account_widgets_la_SOURCES = \
check_c_sources = \
$(libtp_account_widgets_sources) \
$(libtp_account_widgets_headers) \
+ $(uoa_sources) \
$(NULL)
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style
@@ -103,7 +117,7 @@ tpaw-account-widgets-resources.c: tpaw-account-widgets.gresource.xml $(account_w
tpaw-account-widgets-resources.h: tpaw-account-widgets.gresource.xml $(account_widgets_resource_files)
$(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
-EXTRA_DIST = \
+EXTRA_DIST += \
tpaw-account-widgets.gresource.xml \
$(account_widgets_dtd_files) \
$(account_widgets_ui_files) \