summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <philip@tecnocode.co.uk>2011-12-21 11:36:32 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2011-12-21 11:36:32 +0000
commitd275cbfdf2e8914f60925d42755161f014d34ed6 (patch)
tree4704ae50bf17bfc4c3912b94d98450cc99d8362d /docs/reference/Makefile.am
parent506f0999d69d405e8b1d026a470413304ea9f934 (diff)
downloadtotem-pl-parser-d275cbfdf2e8914f60925d42755161f014d34ed6.tar.gz
docs: Automatically generate .types file
This removes one more file we have to maintain.
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
index f366079..dced8da 100644
--- a/docs/reference/Makefile.am
+++ b/docs/reference/Makefile.am
@@ -25,7 +25,7 @@ SCANGOBJ_OPTIONS=
# Extra options to supply to gtkdoc-scan.
# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
-SCAN_OPTIONS=
+SCAN_OPTIONS=--rebuild-types
# Extra options to supply to gtkdoc-mkdb.
# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
@@ -91,6 +91,10 @@ GTKDOC_LIBS=$(top_builddir)/plparse/libtotem-plparser.la $(TOTEM_PLPARSER_LIBS)
# This includes the standard gtk-doc make rules, copied by gtkdocize.
include $(top_srcdir)/gtk-doc.make
+# This should be in gtk-doc.make, since we are calling gtkdoc-scan with
+# --rebuild-types
+SCANOBJ_FILES += $(DOC_MODULE).types
+
# Other files to distribute
# e.g. EXTRA_DIST += version.xml.in
EXTRA_DIST += version.xml.in