summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-05-31 01:36:40 +0100
committerBastien Nocera <hadess@hadess.net>2017-06-08 19:15:04 +0200
commit822efb96d0421bdb56251b36c37118e537a2a388 (patch)
tree066faac76d602caa2d2788aae961a04c8f4082c1 /lib/meson.build
parent21e21b1c0557745ac4304e27b174c187b6aa919e (diff)
downloadtotem-pl-parser-822efb96d0421bdb56251b36c37118e537a2a388.tar.gz
meson: add build for Meson Build System
https://bugzilla.gnome.org/show_bug.cgi?id=783296
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/meson.build b/lib/meson.build
new file mode 100644
index 0000000..2ab00db
--- /dev/null
+++ b/lib/meson.build
@@ -0,0 +1,13 @@
+totem_glibc_sources = ['stub.c']
+
+if not cc.has_function('asprintf')
+ # FIXME: this is untested
+ totem_glibc_sources += ['asprintf.c']
+ cdata.set('asprintf', 'totem_private_asprintf')
+else
+ cdata.set('HAVE_ASPRINTF', true)
+endif
+
+totem_glibc_lib = static_library('totem_glibc',
+ totem_glibc_sources,
+ install: false)