summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2010-12-30 13:59:14 +0100
committerCarlos Garcia Campos <carlosgc@gnome.org>2011-01-08 11:01:20 +0100
commit0bac1fe06a00ae1d1d01e814b039c9dbde356479 (patch)
tree4d07e47183c88dd7528795e099c2d8be3492751c /data/Makefile.am
parente1d489a714f4f1b899b461e8ad13a30c0ce28d64 (diff)
downloadtotem-0bac1fe06a00ae1d1d01e814b039c9dbde356479.tar.gz
Register totem thumbnailer
This was removed in commit 9b403af7a43fe953dd6237f69a378086bd05d087 when migrating to GSettings. This is a new version that doesn't use GConf. Closes: bgo#638346.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 068a83978..a4dc0d7d0 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -65,6 +65,22 @@ CLEANFILES += \
$(desktop_in_files) \
$(desktop_DATA)
+# Thumbnailer
+thumbnailerdir = $(datadir)/thumbnailers
+thumbnailer_in_files = totem.thumbnailer.in
+thumbnailer_DATA = $(thumbnailer_in_files:.thumbnailer.in=.thumbnailer)
+
+totem.thumbnailer: $(thumbnailer_in_files) mime-type-list.txt thumbnailer.sh
+ $(AM_V_GEN)sed -e "s|\@BINDIR\@|$(bindir)|" $< > $@ &&\
+ $(SHELL) $(srcdir)/thumbnailer.sh $(srcdir)/mime-type-list.txt >> $@
+
+EXTRA_DIST += \
+ $(thumbnailer_in_files) \
+ thumbnailer.sh
+
+CLEANFILES += \
+ $(thumbnailer_DATA)
+
# Content type handling
nodist_noinst_HEADERS = totem-mime-types.h nautilus-audio-mime-types.h
totem-mime-types.h: mime-type-include.sh mime-type-list.txt mime-functions.sh