summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2021-05-05 00:00:07 -0300
committerBastien Nocera <hadess@hadess.net>2021-06-29 17:19:33 +0200
commite23c46619ae1996d237e27b75ba80cc2ec23be34 (patch)
tree9df2577173c45b29112bcaa99ba39f2534c2da5c /data/meson.build
parent75e982fc10ba5d3463a1320c0d3cde7bd0ac6f54 (diff)
downloadtotem-e23c46619ae1996d237e27b75ba80cc2ec23be34.tar.gz
preferences: Embed preferences.ui as a GResource
Instead of installing preferences.ui and opening the file, embed it as a GResource and load it using gtk_builder_new_from_resource(). We don't need extra caution because the file is now guaranteed to be embedded into the application. This will be very handy for the next commit where we start using a GtkBuilder template for the preferences dialog.
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/data/meson.build b/data/meson.build
index 4c6df3ba3..b38997400 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -42,7 +42,6 @@ endif
ui_files = files(
'controls.ui',
'playlist.ui',
- 'preferences.ui',
'shortcuts.ui',
'totem.ui',
'uri.ui'
@@ -53,6 +52,14 @@ install_data(
install_dir: totem_pkgdatadir
)
+ui_resources = gnome.compile_resources(
+ 'totemresources',
+ 'totem.gresource.xml',
+ export: true,
+ source_dir: '.',
+ c_name: 'totem'
+)
+
r = run_command(desktop_sh, mime_type_list, uri_schemes_list)
desktop_conf = configuration_data()