summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-09-25 17:01:06 +0200
committerBastien Nocera <hadess@hadess.net>2019-09-25 17:40:44 +0200
commit171d95ba0b92c8806731547ffa08450d4554d162 (patch)
treea06207b78315282a3d19d665fb0a90c507cc2d28 /meson.build
parent307a9f91fb42617fe0cd29ed098eeacdf7c78c3c (diff)
downloadtotem-171d95ba0b92c8806731547ffa08450d4554d162.tar.gz
build: Add support for building Nightly version
This includes renaming a few files that mentioned org.gnome.Totem directly as we want the new nightly build to be parallel installable with a stable version, as org.gnome.Totem.Devel. Closes: #359
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0685d55e0..bd4e87d72 100644
--- a/meson.build
+++ b/meson.build
@@ -41,6 +41,16 @@ totem_debug = get_option('buildtype').contains('debug')
cc = meson.get_compiler('c')
+if get_option('profile') == 'development'
+ profile = '.Devel'
+ name_suffix = ' ☢️'
+else
+ profile = ''
+ name_suffix = ''
+endif
+
+application_id = 'org.gnome.Totem@0@'.format(profile)
+
config_h = configuration_data()
# debug options
@@ -51,6 +61,7 @@ set_defines = [
# package
['PACKAGE', meson.project_name()],
['TOTEM_API_VERSION', totem_api_version],
+ ['APPLICATION_ID', application_id],
['VERSION', totem_version],
# i18n
['GETTEXT_PACKAGE', meson.project_name()]
@@ -229,6 +240,13 @@ meson.add_dist_script(
message('Totem was configured with the following options:')
message('** Using the GStreamer-1.0 backend')
+str = 'Development build'
+if get_option('profile') == 'development'
+ message('** ' + str + ' enabled')
+else
+ message(' ' + str + ' disabled')
+endif
+
str = 'Easy codec installation support'
if have_easy_codec
message('** ' + str + ' enabled')