summaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am42
1 files changed, 9 insertions, 33 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 25abd3083..e4feb24cb 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -1,9 +1,10 @@
-SUBDIRS = $(PLUGINS)
-DIST_SUBDIRS = $(ALL_PLUGINS) totem
+SUBDIRS = screenshot
+#SUBDIRS = $(PLUGINS)
+#DIST_SUBDIRS = $(ALL_PLUGINS)
noinst_LTLIBRARIES = libtotemmodule.la
-common_defines = \
+common_defines = \
-D_REENTRANT \
-DDBUS_API_SUBJECT_TO_CHANGE \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
@@ -18,21 +19,20 @@ common_defines = \
modules_flags = -export_dynamic -avoid-version -module
libtotemmodule_la_SOURCES = \
- totem-module.c \
- totem-module.h \
- totem-plugin.c \
- totem-plugin.h \
totem-plugins-engine.c \
totem-plugins-engine.h \
- totem-plugin-manager.c \
- totem-plugin-manager.h
+ totem-dirs.c \
+ totem-dirs.h
libtotemmodule_la_CPPFLAGS = \
$(common_defines) \
$(AM_CPPFLAGS)
+libtotemmodule_la_LDFLAGS = $(AM_LDFLAGS) $(modules_flags)
+
libtotemmodule_la_CFLAGS = \
$(DEPENDENCY_CFLAGS) \
+ $(PEAS_CFLAGS) \
$(WARN_CFLAGS) \
$(DBUS_CFLAGS) \
$(AM_CFLAGS) \
@@ -43,27 +43,3 @@ libtotemmodule_la_CFLAGS = \
-I$(top_srcdir)/src/backend \
-I$(top_srcdir)/src/plugins
-libtotemmodule_la_LDFLAGS = \
- $(AM_LDFLAGS)
-
-if ENABLE_PYTHON
-
-SUBDIRS += totem
-
-libtotemmodule_la_LIBADD = \
- $(DEPENDENCY_LIBS) \
- $(PYTHON_LIBS) \
- $(PYTHON_EXTRA_LIBS) \
- $(PYGTK_LIBS)
-
-libtotemmodule_la_SOURCES += \
- totem-python-module.c \
- totem-python-module.h \
- totem-python-plugin.c \
- totem-python-plugin.h
-
-libtotemmodule_la_CFLAGS += \
- $(NO_STRICT_ALIASING_CFLAGS) \
- $(PYGTK_CFLAGS) \
- $(PYTHON_CFLAGS)
-endif