summaryrefslogtreecommitdiff
path: root/src/plugins/sample-vala/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/sample-vala/Makefile.am')
-rw-r--r--src/plugins/sample-vala/Makefile.am30
1 files changed, 0 insertions, 30 deletions
diff --git a/src/plugins/sample-vala/Makefile.am b/src/plugins/sample-vala/Makefile.am
deleted file mode 100644
index f82f2e388..000000000
--- a/src/plugins/sample-vala/Makefile.am
+++ /dev/null
@@ -1,30 +0,0 @@
-include $(top_srcdir)/src/plugins/Makefile.plugins
-
-plugindir = $(PLUGINDIR)/sample-vala
-plugin_LTLIBRARIES = libsample-vala.la
-
-plugin_in_files = sample-vala.plugin.in
-
-# here we are explicitly specifying gtk+-3.0 to use the vapi because vala still
-# cannot parse the gir
-AM_VALAFLAGS = \
- --girdir=$(abs_top_builddir)/src \
- --pkg Totem-1.0 --pkg libpeas-1.0 --pkg gtk+-3.0
-
-libsample_vala_la_SOURCES = totem-sample-vala-plugin.vala
-libsample_vala_la_LDFLAGS = $(plugin_ldflags)
-libsample_vala_la_CFLAGS = $(plugin_cflags) $(vala_plugin_cflags)
-libsample_vala_la_LIBADD = $(plugin_libadd)
-
-GITIGNOREFILES = \
- $(libsample_vala_la_SOURCES:.vala=.c) \
- libsample_vala_la_vala.stamp \
- $(NULL)
-
-# Override to _not_ install the test plugins
-install-pluginLTLIBRARIES:
-install-pluginDATA:
-uninstall-pluginLTLIBRARIES:
-uninstall-pluginDATA:
-
--include $(top_srcdir)/git.mk