summaryrefslogtreecommitdiff
path: root/examples/libtracker-sparql/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2011-04-01 15:35:10 +0200
committerJürg Billeter <j@bitron.ch>2011-04-04 12:12:35 +0200
commit0ec9878654c9b233de2193043870dd9f2e1fab9e (patch)
tree679dfac82552790f584e19fc994ff206d49b872e /examples/libtracker-sparql/Makefile.am
parent8c9074f17d235301ff5767d09b87323e091fffa0 (diff)
downloadtracker-0ec9878654c9b233de2193043870dd9f2e1fab9e.tar.gz
libtracker-sparql: Use static linking instead of plugins
Plugin loading in threads may be problematic in certain environments. As we do not currently support external plugins anyway, this changes libtracker-bus and libtracker-direct to be part of libtracker-sparql. This will also slightly improve initialization performance. Fixes NB#241659.
Diffstat (limited to 'examples/libtracker-sparql/Makefile.am')
-rw-r--r--examples/libtracker-sparql/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/libtracker-sparql/Makefile.am b/examples/libtracker-sparql/Makefile.am
index aaecc6afb..ef417f9fe 100644
--- a/examples/libtracker-sparql/Makefile.am
+++ b/examples/libtracker-sparql/Makefile.am
@@ -6,7 +6,7 @@ AM_CPPFLAGS = $(BUILD_CFLAGS) \
-I$(top_srcdir)/src \
$(LIBTRACKER_SPARQL_CFLAGS)
-LDADD = $(top_builddir)/src/libtracker-sparql/libtracker-sparql-$(TRACKER_API_VERSION).la \
+LDADD = $(top_builddir)/src/libtracker-sparql-backend/libtracker-sparql-$(TRACKER_API_VERSION).la \
$(BUILD_LIBS) \
$(LIBTRACKER_SPARQL_LIBS)