summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2022-07-22 18:24:49 +0200
committerCarlos Garnacho <carlosg@gnome.org>2023-01-11 17:57:51 +0000
commit236bc958f0e01428dc132ffd908f5c3a6047326b (patch)
tree1e743a5bcbc145fdee2ebe4b6a6a62f150c9adb8 /meson.build
parent775381a33db65deafcb3045dbb8c0394c5803f76 (diff)
downloadtracker-236bc958f0e01428dc132ffd908f5c3a6047326b.tar.gz
build: Auto-generate VAPI
The autogenerated version has a more intuitive API on Vala and is more up-to-date
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 67ddb0901..1e0f7dd43 100644
--- a/meson.build
+++ b/meson.build
@@ -100,6 +100,10 @@ if get_option('tests')
endif
python = import('python').find_installation('python3', modules: py_modules)
+if get_option('vapi').enabled() and get_option('introspection').disabled()
+ error('Vala binding generation requires the \'introspection\' to be enabled')
+endif
+
cc_warning_flags = [
'-Wformat',
'-Wformat-security',
@@ -340,8 +344,6 @@ tracker_internal_libs_dir = join_paths(get_option('prefix'), get_option('libdir'
# the ontology is installed to the same location.
tracker_ontologies_dir = join_paths(get_option('prefix'), get_option('datadir'), tracker_versioned_name, 'ontologies')
-vapi_dir = join_paths(get_option('prefix'), get_option('datadir'), 'vala', 'vapi')
-
if gobject_introspection.found()
typelib_dir = gobject_introspection.get_variable(pkgconfig: 'typelibdir',
pkgconfig_define: [ 'libdir', libdir ])