summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-08-28 16:40:21 +0200
committerCarlos Garnacho <carlosg@gnome.org>2022-08-30 16:56:47 +0000
commit5904dbba635dc85d989ef36191bd54465034d2b4 (patch)
treeb620d2df974f1c5981e8f7efb3d20871527eb381 /meson.build
parent051359acecdab6eedc36c781217de54bcb5c2d06 (diff)
downloadtracker-5904dbba635dc85d989ef36191bd54465034d2b4.tar.gz
build: Use generic .get_variable method to get pkgconfig variables
This generic method is available since meson 0.51 (which we already require), while pkg.get_pkgconfig_variable is deprecated in 0.56.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 391170400..7bac74192 100644
--- a/meson.build
+++ b/meson.build
@@ -236,8 +236,8 @@ endif
####################################################################
if get_option('dbus_services_dir') == ''
- dbus_services_dir = dbus.get_pkgconfig_variable('session_bus_services_dir',
- define_variable: [ 'datadir', datadir ])
+ dbus_services_dir = dbus.get_variable(pkgconfig: 'session_bus_services_dir',
+ pkgconfig_define: [ 'datadir', datadir ])
else
dbus_services_dir = get_option('dbus_services_dir')
endif
@@ -253,8 +253,8 @@ if install_systemd_user_services
if systemd_user_services_dir == ''
systemd = dependency('systemd', version: '>= 242', required: false)
if systemd.found()
- systemd_user_services_dir = systemd.get_pkgconfig_variable('systemduserunitdir',
- define_variable: ['prefix', get_option('prefix')])
+ systemd_user_services_dir = systemd.get_variable(pkgconfig: 'systemduserunitdir',
+ pkgconfig_define: ['prefix', get_option('prefix')])
else
error('systemd user services were enabled, but systemd was not found. ' +
'Please set the systemd_user_services_dir option if you want to ' +
@@ -273,8 +273,8 @@ if get_option('bash_completion')
if bash_completion_dir == ''
bash_completion_package = dependency('bash-completion', required: false)
if bash_completion_package.found()
- bash_completion_dir = bash_completion_package.get_pkgconfig_variable('completionsdir',
- define_variable: [ 'prefix', get_option('prefix') ])
+ bash_completion_dir = bash_completion_package.get_variable(pkgconfig: 'completionsdir',
+ pkgconfig_define: [ 'prefix', get_option('prefix') ])
else
bash_completion_dir = join_paths(datadir, 'bash-completion', 'completions')
endif
@@ -342,8 +342,8 @@ tracker_ontologies_dir = join_paths(get_option('prefix'), get_option('datadir'),
vapi_dir = join_paths(get_option('prefix'), get_option('datadir'), 'vala', 'vapi')
if gobject_introspection.found()
- typelib_dir = gobject_introspection.get_pkgconfig_variable('typelibdir',
- define_variable: [ 'libdir', libdir ])
+ typelib_dir = gobject_introspection.get_variable(pkgconfig: 'typelibdir',
+ pkgconfig_define: [ 'libdir', libdir ])
endif
subdir('src')