summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-12-10 23:25:24 +0100
committerCarlos Garnacho <carlosg@gnome.org>2022-12-11 19:38:27 +0100
commit8c56e45da7b1e0972264ba9a1f7e2e5d1a54bdf2 (patch)
treebc72f7222e26e6bb2f834187be6f09044310c723 /meson.build
parentcbd74b3c95d6569c27c3a7a7c574802acd198a85 (diff)
downloadtracker-8c56e45da7b1e0972264ba9a1f7e2e5d1a54bdf2.tar.gz
build: Build GVDB as a Meson subproject
Since recently, GVDB repository includes a minimal meson.build file to allow building as a subproject without additional hassles (e.g. shipping supporting files at /subprojects/repofiles/) Drop our internal copy of GVDB in favor of a subproject built through Meson. Since we're updating many years across, there has been GVDB API updates that we need to adapt to: GvdbTable is no longer a refcounted object, and gvdb_table_walk() is no longer offered to iterate across values. These largely affect our own set of GVDB tests though, the test for gvdb_table_walk() was dropped, and so is the ref/unref one (it basically does the same than gvdb/flat_strings, after dropping the refcounting). These remaining tests stay useful, and should ideally move into the GVDB repository, so it can run as a separate suite here.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a72b21b70..67ddb0901 100644
--- a/meson.build
+++ b/meson.build
@@ -55,6 +55,8 @@ libxml2 = dependency('libxml-2.0', version: '> 2.6')
sqlite = dependency('sqlite3', version: '>' + sqlite_required)
dbus = dependency('dbus-1')
+gvdb_dep = dependency('gvdb')
+
soup = get_option('soup')
if soup.contains('soup2') or soup.contains('auto')
libsoup2 = dependency('libsoup-2.4', version: '> 2.40',