summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-04-24 11:14:59 +0000
committerCarlos Garnacho <carlosg@gnome.org>2022-04-24 11:14:59 +0000
commitb496b38b45ac493c16f619b49739208a4790a427 (patch)
tree471b207bd1c63ada3f4c37297fa8c3d5c4a33946 /meson.build
parentf9f354d55a07011dd1a9b879ff9e112c1f1c4064 (diff)
parentac987cec47baf6f56af3972a962f3329abf20cc9 (diff)
downloadtracker-b496b38b45ac493c16f619b49739208a4790a427.tar.gz
Merge branch 'wip/carlosg/shuffle-dirs' into 'master'
Build libtracker-sparql as a monolithic library See merge request GNOME/tracker!504
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 4 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index bb370a806..ebb9acca1 100644
--- a/meson.build
+++ b/meson.build
@@ -39,7 +39,8 @@ glib_required = '2.52.0'
# 3.7.15 for sqlite3_errstr() support
# 3.8.3 for SQLITE_DETERMINISTIC
# 3.15.0 for https://sqlite.org/rowvalue.html
-sqlite_required = '3.15.0'
+# 3.20.0 for builtin FTS5
+sqlite_required = '3.20.0'
gio = dependency('gio-2.0', version: '>' + glib_required)
gio_unix = dependency('gio-unix-2.0', version: '>' + glib_required)
@@ -190,21 +191,11 @@ else
error('Failed to compile SQLite FTS test.')
endif
- if result.returncode() == 0
- sqlite3_has_builtin_fts5 = true
- else
- sqlite3_has_builtin_fts5 = false
+ if result.returncode() != 0
+ error('SQLite has no builtin FTS5.')
endif
endif
-if sqlite3_has_builtin_fts5
- message('Using sqlite3 builtin FTS module')
-elif sqlite.version().version_compare('>= 3.20.0')
- error('FTS support was enabled but SQLite doesn\'t have the FTS module built in')
-else
- message('sqlite3 is older than version 3.20.0, using FTS module that is bundled with Tracker')
-endif
-
##################################################################
# Check for libtracker-data and libtracker-fts: Unicode support
#
@@ -298,7 +289,6 @@ conf = configuration_data()
# Config that goes in config.h
-conf.set('HAVE_BUILTIN_FTS', sqlite3_has_builtin_fts5)
conf.set('HAVE_LIBICU', unicode_library_name == 'icu')
conf.set('HAVE_LIBSTEMMER', have_libstemmer)
conf.set('HAVE_LIBUNISTRING', unicode_library_name == 'unistring')
@@ -414,7 +404,6 @@ summary = [
' Compiler: ' + cc.get_id(),
'\nFeature Support:',
' Unicode support library: ' + unicode_library_name,
- ' Use external FTS module: ' + (not sqlite3_has_builtin_fts5).to_string(),
' Build with Stemming support: ' + have_libstemmer.to_string(),
' API documentation: ' + get_option('docs').to_string(),
' CLI documentation (manpages): ' + get_option('man').to_string(),