summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2022-02-16 10:59:33 -0800
committerCarlos Garnacho <carlosg@gnome.org>2022-02-20 14:43:27 +0000
commitdb36d010737d5eeceff300e3dd5e315c5d0382a2 (patch)
treebc450d0885f2232aa80a24168135ea257a1958c5 /meson.build
parentc6e63fd718231bbef0ee4d8756a333a4500378fc (diff)
downloadtracker-db36d010737d5eeceff300e3dd5e315c5d0382a2.tar.gz
build: Add an option to control building tests
Commit 8569c99d2926 ("Look for a Python installation with the tap module") correctly added a dependency on the gi Python module for tests. Commit 51ca035697a4 ("Make tracker:endpoint test work on macOS") restructured Python probing by moving it to the top-level meson.build. These two commits have the side-effect of exposing the fact that the gi Python module is really only a test dependency, and should not be required if building without tests. As such, add a -Dtests=bool option to disable building tests. This reduces the number of ninja targets from 232 to 188 on my non-test build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 4e59b8240..f4dd58fd4 100644
--- a/meson.build
+++ b/meson.build
@@ -75,9 +75,12 @@ if get_option('man')
a2x = find_program('a2x')
endif
-py_modules = ['gi']
-if get_option('tests_tap_protocol')
- py_modules += 'tap'
+py_modules = []
+if get_option('tests')
+ py_modules += 'gi'
+ if get_option('tests_tap_protocol')
+ py_modules += 'tap'
+ endif
endif
python = import('python').find_installation('python3', modules: py_modules)
@@ -358,7 +361,9 @@ tracker_uninstalled_nepomuk_ontologies_dir = join_paths(meson.current_source_dir
tracker_uninstalled_stop_words_dir = join_paths(meson.current_source_dir(), 'src', 'libtracker-common', 'stop-words')
tracker_uninstalled_testutils_dir = join_paths(meson.current_source_dir(), 'utils')
-subdir('tests')
+if get_option('tests')
+ subdir('tests')
+endif
subdir('examples')
subdir('po')