summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-04-02 21:44:50 +0200
committerCarlos Garnacho <carlosg@gnome.org>2022-04-02 21:50:12 +0200
commitde16136f286d11af8ada333b67f95ec6155d891e (patch)
tree64e396f482360e86eb88d1f434e5ad71ed56e069 /meson.build
parent06b5759f39a7ace0bbcacd04b27ca48fc11561ec (diff)
downloadtracker-de16136f286d11af8ada333b67f95ec6155d891e.tar.gz
build: Depend on sqlite >=3.20.0
Back in the day, 3.20.0 was stablished as the baseline to expect a builtin fts5 module, due to module loading API changes in sqlite. Fast forward to today, this version was released in Aug 2017 so it is old enough to bump the dependency. This will allow us to drop our in-tree fts5 module.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 253028b70..1ae34ceb4 100644
--- a/meson.build
+++ b/meson.build
@@ -39,7 +39,8 @@ glib_required = '2.52.0'
# 3.7.15 for sqlite3_errstr() support
# 3.8.3 for SQLITE_DETERMINISTIC
# 3.15.0 for https://sqlite.org/rowvalue.html
-sqlite_required = '3.15.0'
+# 3.20.0 for builtin FTS5
+sqlite_required = '3.20.0'
gio = dependency('gio-2.0', version: '>' + glib_required)
gio_unix = dependency('gio-unix-2.0', version: '>' + glib_required)