summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorSam Thursfield <sam@afuera.me.uk>2019-09-28 14:44:07 +0200
committerSam Thursfield <sam@afuera.me.uk>2019-09-28 15:12:50 +0200
commit1a787fa4fd667bb7727995fd26e35b2214f3f1f7 (patch)
treed40afcdd36715af5165e4dbe705dc2a656c50d14 /meson_options.txt
parent763d4f05f11c0b51105c44fc833d043fd1c86520 (diff)
downloadtracker-1a787fa4fd667bb7727995fd26e35b2214f3f1f7.tar.gz
utils/trackertestutils: Make it usable by other projects
This commit makes the tracker-testutils-2.0 package more reusable. The idea is that projects using Tracker can use this as a way to sandbox their test suites from the user's real Tracker data. In your meson.build file you would do something like this to locate the script and run your test. python3 = find_program('python3') trackertestutils = dependency('tracker-testutils-2.0') tracker_sandbox_command = find_program(trackertestutils.get_pkgconfig_variable('command')) test('myapptest', tracker_sandbox_command, args: ['--index-tmpdir', my_app_test_executable]) This would ensure that XDG_CACHE_HOME and XDG_DATA_HOME point to a temporary directory, separate from any real Tracker index data that the current user might have inside their XDG cache & data directories.
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson_options.txt b/meson_options.txt
index d4b3b2a81..509b3479f 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -23,6 +23,6 @@ option('dbus_services', type: 'string', value: '',
option('systemd_user_services', type: 'string', value: 'yes',
description: 'Directory to install systemd user .service files (or "yes" for default directory, "no" to disable installation)')
option('test_utils', type: 'boolean', value: true,
- description: 'Whether to install the tracker test utils')
+ description: 'Whether to install the trackertestutils Python package')
option('test_utils_dir', type: 'string', value: '',
- description: 'Directory to install tracker test utils (or empty to use the default)')
+ description: 'Directory to install trackertestutils Python package (or empty to use the default)')