summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2022-02-16 10:59:33 -0800
committerCarlos Garnacho <carlosg@gnome.org>2022-02-20 14:43:27 +0000
commitdb36d010737d5eeceff300e3dd5e315c5d0382a2 (patch)
treebc450d0885f2232aa80a24168135ea257a1958c5 /meson_options.txt
parentc6e63fd718231bbef0ee4d8756a333a4500378fc (diff)
downloadtracker-db36d010737d5eeceff300e3dd5e315c5d0382a2.tar.gz
build: Add an option to control building tests
Commit 8569c99d2926 ("Look for a Python installation with the tap module") correctly added a dependency on the gi Python module for tests. Commit 51ca035697a4 ("Make tracker:endpoint test work on macOS") restructured Python probing by moving it to the top-level meson.build. These two commits have the side-effect of exposing the fact that the gi Python module is really only a test dependency, and should not be required if building without tests. As such, add a -Dtests=bool option to disable building tests. This reduces the number of ninja targets from 232 to 188 on my non-test build.
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index a7e647d02..ec8ea8bc2 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -20,6 +20,8 @@ option('systemd_user_services', type: 'boolean', value: true, yield: true,
description: 'Whether to install systemd user .service files')
option('systemd_user_services_dir', type: 'string', value: '', yield: true,
description: 'Directory to install systemd user unit files (or empty to use default)')
+option('tests', type: 'boolean', value: true,
+ description: 'Whether to build tests')
option('test_utils', type: 'boolean', value: true,
description: 'Whether to install the trackertestutils Python package')
option('test_utils_dir', type: 'string', value: '',