summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJamie McCracken <jamiemcc@src.gnome.org>2006-11-07 00:38:36 +0000
committerJamie McCracken <jamiemcc@src.gnome.org>2006-11-07 00:38:36 +0000
commitc0bb74c6c195c4b97ec192c4d1632e706d375f2d (patch)
treec3b79b55c5f8ac53ca1e8e4cbb8d4fb7e7a7ade1 /src/Makefile.am
parent41bccb1851219900e68093cccea9e14a25ee5ee3 (diff)
downloadtracker-c0bb74c6c195c4b97ec192c4d1632e706d375f2d.tar.gz
build updates
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 417758fbd..16f1598ce 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,5 +6,12 @@ else
tracker_gui_dir =
endif
-SUBDIRS = libstemmer sqlite3 text-filters trackerd libtracker tracker-extract $(tracker_gui_dir)
-DIST_SUBDIRS = libstemmer sqlite3 text-filters trackerd libtracker tracker-extract $(tracker_gui_dir)
+if USING_EXTERNAL_SQLITE
+sqlite_dir =
+else
+sqlite_dir = sqlite3
+endif
+
+
+SUBDIRS = libstemmer $(sqlite_dir) text-filters trackerd libtracker tracker-extract $(tracker_gui_dir)
+DIST_SUBDIRS = libstemmer $(sqlite_dir) text-filters trackerd libtracker tracker-extract $(tracker_gui_dir)