summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartyn James Russell <mr@src.gnome.org>2009-02-23 12:08:43 +0000
committerMartyn James Russell <mr@src.gnome.org>2009-02-23 12:08:43 +0000
commitf3574723b05f49a6f33b02076961494b8c7147b9 (patch)
treee2f98a2b39ab12928dd607630c7211d51b8301d0 /src/Makefile.am
parent6606c0644f35d41e2a3cce9f5d174349ca527fe8 (diff)
downloadtracker-f3574723b05f49a6f33b02076961494b8c7147b9.tar.gz
Fixed tracker-search-tool, tracker-preferences, tracker-applet and the
* configure.ac: * data/Makefile.am: * docs/manpages/Makefile.am: * python/deskbar-handler/Makefile.am: * python/deskbar-handler/tracker-module.py: * src/Makefile.am: Fixed tracker-search-tool, tracker-preferences, tracker-applet and the deskbar-applet enable/disable switches in configure. Also fixed the deskbar-applet so it actually errors when using --enable-deskbar-applet instead of doing nothing when we don't have it available. svn path=/trunk/; revision=2956
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e30f53ec4..138d23885 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,9 +1,5 @@
include $(top_srcdir)/Makefile.decl
-if HAVE_GNOME
-build_tracker_search_tool = tracker-search-tool
-endif
-
if HAVE_INOTIFY
build_libinotify = libinotify
endif
@@ -16,18 +12,22 @@ if ENABLE_SQLITE_FTS
build_sqlite_fts = tracker-fts
endif
-if ENABLE_TRACKER_PREFERENCES
+if HAVE_TRACKER_PREFERENCES
build_tracker_preferences = tracker-preferences
endif
-if ENABLE_TRACKER_APPLET
+if HAVE_TRACKER_APPLET
build_tracker_applet = tracker-applet
endif
-if ENABLE_LIBTRACKERGTK
+if HAVE_LIBTRACKERGTK
build_libtrackergtk = libtracker-gtk
endif
+if HAVE_TRACKER_SEARCH_TOOL
+build_tracker_search_tool = tracker-search-tool
+endif
+
SUBDIRS = \
libstemmer \
$(build_qdbm) \