summaryrefslogtreecommitdiff
path: root/tests/common/meson.build
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2017-08-04 00:08:35 +0100
committerSam Thursfield <sam.thursfield@codethink.co.uk>2017-08-04 00:08:35 +0100
commit439b44f26723fdf15f5ae00dcf5d3f5921165143 (patch)
treec37ec6dac75732806573326da939ffa3d14012ba /tests/common/meson.build
parent04c47c51cee373f0296e277a852c38663edc0245 (diff)
downloadtracker-439b44f26723fdf15f5ae00dcf5d3f5921165143.tar.gz
meson: Replace all source_root() and build_root() calls
These functions need to be avoided so that Tracker doesn't break when included via subproject() into another Meson project.
Diffstat (limited to 'tests/common/meson.build')
-rw-r--r--tests/common/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/common/meson.build b/tests/common/meson.build
index 2598745fa..184b33d82 100644
--- a/tests/common/meson.build
+++ b/tests/common/meson.build
@@ -4,7 +4,7 @@ libtracker_testcommon = library('tracker-testcommon',
'tracker-test-helpers.c',
dependencies: tracker_testcommon_dependencies,
c_args: [
- '-DTEST_TEXT="@0@/tests/libtracker-common/non-utf8.txt"'.format(meson.source_root()),
+ '-DTEST_TEXT="@0@/../libtracker-common/non-utf8.txt"'.format(meson.current_source_dir()),
]
)