summaryrefslogtreecommitdiff
path: root/tests/gvdb/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-12-10 23:25:24 +0100
committerCarlos Garnacho <carlosg@gnome.org>2022-12-11 19:38:27 +0100
commit8c56e45da7b1e0972264ba9a1f7e2e5d1a54bdf2 (patch)
treebc72f7222e26e6bb2f834187be6f09044310c723 /tests/gvdb/meson.build
parentcbd74b3c95d6569c27c3a7a7c574802acd198a85 (diff)
downloadtracker-8c56e45da7b1e0972264ba9a1f7e2e5d1a54bdf2.tar.gz
build: Build GVDB as a Meson subproject
Since recently, GVDB repository includes a minimal meson.build file to allow building as a subproject without additional hassles (e.g. shipping supporting files at /subprojects/repofiles/) Drop our internal copy of GVDB in favor of a subproject built through Meson. Since we're updating many years across, there has been GVDB API updates that we need to adapt to: GvdbTable is no longer a refcounted object, and gvdb_table_walk() is no longer offered to iterate across values. These largely affect our own set of GVDB tests though, the test for gvdb_table_walk() was dropped, and so is the ref/unref one (it basically does the same than gvdb/flat_strings, after dropping the refcounting). These remaining tests stay useful, and should ideally move into the GVDB repository, so it can run as a separate suite here.
Diffstat (limited to 'tests/gvdb/meson.build')
-rw-r--r--tests/gvdb/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/gvdb/meson.build b/tests/gvdb/meson.build
index 558f0f4e2..5cdf4ac9a 100644
--- a/tests/gvdb/meson.build
+++ b/tests/gvdb/meson.build
@@ -1,6 +1,6 @@
gvdb_test = executable('gvdb-test',
'gvdb-test.c',
- dependencies: gvdb_dep,
+ dependencies: [gio, gvdb_dep],
include_directories: configinc,
)