summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2019-10-01 03:43:18 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2019-10-01 03:55:01 +0200
commit8a747ea71e3840cbd8e771ea5c6b17e2657fc7a9 (patch)
tree04d3a55b5be4e9862da8e332e72a12d3957555c9 /tests/meson.build
parent07df7002f71a243b4c983d65aaa8e630cf19fa73 (diff)
downloadtracker-8a747ea71e3840cbd8e771ea5c6b17e2657fc7a9.tar.gz
tests: Use meson suites
Make possible to easily (not) run a sub-set of tests by using suites in tracker. Fixes https://gitlab.gnome.org/GNOME/tracker/issues/153
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build13
1 files changed, 8 insertions, 5 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 2e19b0623..c7467781a 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -28,6 +28,7 @@ test_bus_conf_file = configure_file(
foreach t: tests
test_name = t.get('name')
test_exe = t.get('exe')
+ test_suite = t.get('suite', [])
test_timeout = t.get('timeout', 30)
# This flag marks unit tests which can't run alongside other unit tests. It
@@ -47,17 +48,19 @@ foreach t: tests
test_env.set('LANG', 'en_US.UTF8')
if test_requires_dbus
- test (test_name, dbus_run_session,
+ test(test_name, dbus_run_session,
env: test_env,
args: ['--config-file=@0@'.format(join_paths(meson.current_build_dir(), 'test-bus.conf')),
'--',
test_exe],
+ suite: test_suite,
timeout: test_timeout,
is_parallel: test_is_parallel)
else
- test (test_name, test_exe,
- env: test_env,
- timeout: test_timeout,
- is_parallel: test_is_parallel)
+ test(test_name, test_exe,
+ env: test_env,
+ timeout: test_timeout,
+ suite: test_suite,
+ is_parallel: test_is_parallel)
endif
endforeach