summaryrefslogtreecommitdiff
path: root/utils/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2022-02-27 16:19:18 +0100
committerCarlos Garnacho <carlosg@gnome.org>2022-02-27 16:45:47 +0100
commitebd4b50a28a8c32d981052d9f8283d24ab97d886 (patch)
tree0e40937d16a38d366ca5418dec15644bac01a647 /utils/meson.build
parentf1f4050c1a4e67fe2b54f2afc817e8bffd8f1a0c (diff)
downloadtracker-ebd4b50a28a8c32d981052d9f8283d24ab97d886.tar.gz
utils: Add benchmark utility
This executable is only built in-tree and not installed, mostly useful so developers can check performance improvements and regressions. For reference and future baseline, the output is: ``` $ ./utils/benchmark/tracker-benchmark Batch size: 5000, Individual test duration: 30 sec Opening in-memory database… Test Elements Elems/sec Min Max Avg Resource batch update (sync) 1016148,459 33871,615 27,302 usec 40,300 usec 29,523 usec SPARQL batch update (sync) 365763,206 12192,107 76,743 usec 93,013 usec 82,020 usec Prepared statement query (sync) 1931876,356 64395,879 13,000 usec 5,158 msec 15,529 usec SPARQL query (sync) 220222,325 7340,744 123,000 usec 1,350 msec 136,226 usec ``` This is on an Intel Core i5-6200U CPU.
Diffstat (limited to 'utils/meson.build')
-rw-r--r--utils/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/utils/meson.build b/utils/meson.build
index d571a582b..a13458910 100644
--- a/utils/meson.build
+++ b/utils/meson.build
@@ -1,3 +1,4 @@
+subdir('benchmark')
subdir('mtp')
subdir('tracker-resdump')
subdir('trackertestutils')