summaryrefslogtreecommitdiff
path: root/docs/reference/ontology/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/ontology/Makefile.am')
-rw-r--r--docs/reference/ontology/Makefile.am56
1 files changed, 0 insertions, 56 deletions
diff --git a/docs/reference/ontology/Makefile.am b/docs/reference/ontology/Makefile.am
deleted file mode 100644
index 42fe722c5..000000000
--- a/docs/reference/ontology/Makefile.am
+++ /dev/null
@@ -1,56 +0,0 @@
-AUTOMAKE_OPTIONS = 1.6
-
-# The original Ontology explanation files
-ONTOLOGY_INTRODUCTIONS = \
- mfo-introduction.xml \
- mlo-introduction.xml \
- nco-introduction.xml \
- nie-introduction.xml \
- nmm-introduction.xml \
- nmo-introduction.xml \
- xsd-introduction.xml
-
-# Generation of the ontology XML files.
-gen-doc.stamp: $(ONTOLOGY_INTRODUCTIONS)
- $(MKDIR_P) xml
- $(top_builddir)/docs/tools/ttl2sgml -d $(top_srcdir)/src/ontologies/nepomuk -o xml/
- $(AM_V_GEN) touch $@
-
-version.xml: gen-doc.stamp
-
-# The name of the module.
-DOC_MODULE = ontology
-
-# The top-level SGML file.
-DOC_MAIN_SGML_FILE = ontology-docs.sgml
-
-# The directory containing the source code. Relative to $(srcdir)
-DOC_SOURCE_DIR = .
-
-# Extra options to supply to gtkdoc-mkdb
-MKDB_OPTIONS = --sgml-mode --output-format=xml
-
-# Extra options to supply to gtkdoc-mkhtml
-MKHTML_OPTIONS=--path="$(abs_builddir)"
-
-# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE)
-content_files = \
- version.xml
-
-expand_content_files =
-
-# Extra options to supply to gtkdoc-fixref
-FIXXREF_OPTIONS =
-
-include $(top_srcdir)/gtk-doc.make
-
-# Other files to distribute
-# Note that HTML_FILES and content_files are already included
-# by gtk-doc
-EXTRA_DIST += \
- version.xml.in \
- $(ONTOLOGY_INTRODUCTIONS) \
- meson.build
-
-CLEANFILES += \
- gen-doc.stamp