summaryrefslogtreecommitdiff
path: root/examples/class-signal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/class-signal/Makefile.am')
-rw-r--r--examples/class-signal/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/examples/class-signal/Makefile.am b/examples/class-signal/Makefile.am
index 6657faadc..313b8fdaf 100644
--- a/examples/class-signal/Makefile.am
+++ b/examples/class-signal/Makefile.am
@@ -5,12 +5,20 @@ noinst_PROGRAMS = class-signal
AM_CPPFLAGS = \
$(BUILD_CFLAGS) \
-I$(top_srcdir)/src \
- $(LIBTRACKER_SPARQL_CFLAGS)
+ $(LIBTRACKER_SPARQL_CFLAGS) \
+ $(TRACKER_DBUS_CFLAGS)
LDADD = \
$(top_builddir)/src/libtracker-sparql/libtracker-sparql-$(TRACKER_API_VERSION).la \
$(BUILD_LIBS) \
- $(LIBTRACKER_SPARQL_LIBS)
+ $(LIBTRACKER_SPARQL_LIBS) \
+ $(TRACKER_DBUS_LIBS)
-class_signal_SOURCES = class-signal.c
+# NOTE: class-signal needed to have gio/dbus/dbus-glib-1 CFLAGS/LIBS
+# added. The reason for this is that the
+# LIBTRACKER_SPARQL_{CFLAGS|LIBS} no longer include dbus/dbus-glib-1
+# so these tests fail without that. The fix is to update the test
+# cases to use gdbus. For now this is a temporary fix for these tests,
+# -mr.
+class_signal_SOURCES = class-signal.c