summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build13
1 files changed, 8 insertions, 5 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 2e19b0623..c7467781a 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -28,6 +28,7 @@ test_bus_conf_file = configure_file(
foreach t: tests
test_name = t.get('name')
test_exe = t.get('exe')
+ test_suite = t.get('suite', [])
test_timeout = t.get('timeout', 30)
# This flag marks unit tests which can't run alongside other unit tests. It
@@ -47,17 +48,19 @@ foreach t: tests
test_env.set('LANG', 'en_US.UTF8')
if test_requires_dbus
- test (test_name, dbus_run_session,
+ test(test_name, dbus_run_session,
env: test_env,
args: ['--config-file=@0@'.format(join_paths(meson.current_build_dir(), 'test-bus.conf')),
'--',
test_exe],
+ suite: test_suite,
timeout: test_timeout,
is_parallel: test_is_parallel)
else
- test (test_name, test_exe,
- env: test_env,
- timeout: test_timeout,
- is_parallel: test_is_parallel)
+ test(test_name, test_exe,
+ env: test_env,
+ timeout: test_timeout,
+ suite: test_suite,
+ is_parallel: test_is_parallel)
endif
endforeach