summaryrefslogtreecommitdiff
path: root/build-aux/gcc-warning.spec
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-09-01 01:51:06 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-09-01 01:51:37 -0700
commit157c42eff782e18fd921b2815f5869c1f53edde7 (patch)
tree181369ad8350856258522fc429d684ce7fe0464d /build-aux/gcc-warning.spec
parent1f5bc60c497c2b801681a3362c214fcf6a68f24a (diff)
downloadgnulib-157c42eff782e18fd921b2815f5869c1f53edde7.tar.gz
manywarnings: add GCC 4.9 warnings
Also, make it easier to maintain this in the future. * build-aux/gcc-warning.spec: Add -Wabi-tag, -Wconditionally-supported, -Wdelete-incomplete, -Winherited-variadic-ctor, -Wvirtual-move-assign, -Wzerotrip. Remove duplicates. Use tabs uniformly, as that's what 'cut' wants. * m4/manywarnings.m4 (gl_MANYWARN_ALL_GCC): Add -Wdate-time, -Wopenmp-simd. Use -fdiagnostics-show-option and -funit-at-a-time only for older GCC versions that need them. Handke -Wnormalized=nfc specially, so that the 'comm' command used for maintenance doesn't get confused.
Diffstat (limited to 'build-aux/gcc-warning.spec')
-rw-r--r--build-aux/gcc-warning.spec21
1 files changed, 10 insertions, 11 deletions
diff --git a/build-aux/gcc-warning.spec b/build-aux/gcc-warning.spec
index 74c6503b9b..1c250dcb46 100644
--- a/build-aux/gcc-warning.spec
+++ b/build-aux/gcc-warning.spec
@@ -1,6 +1,7 @@
# options to filter out, and why
--all-warnings alias for -Wall
--extra-warnings alias for -Wextra
+-Wabi-tag c++
-Waggregate-return obsolescent
-Waliasing fortran
-Walign-commons fortran
@@ -11,16 +12,16 @@
-Wc++0x-compat c++
-Wc++11-compat c++
-Wc-binding-type fortran
--Wc-binding-type fortran
-Wcast-qual FIXME maybe? too much noise; encourages bad changes
-Wcharacter-truncation fortran
--Wcompare-reals fortran
+-Wcompare-reals fortran
+-Wconditionally-supported c++ and objc++
-Wconversion FIXME maybe? too much noise; encourages bad changes
-Wconversion-extra fortran
-Wconversion-null c++ and objc++
-Wctor-dtor-privacy c++
-Wdeclaration-after-statement FIXME: do not want. others may
--Wdeclaration-after-statement obsolescent
+-Wdelete-incomplete c++ and objc++
-Wdelete-non-virtual-dtor c++
-Weffc++ c++
-Werror-implicit-function-declaration deprecated
@@ -30,6 +31,7 @@
-Wfunction-elimination fortran
-Wimplicit-interface fortran
-Wimplicit-procedure fortran
+-Winherited-variadic-ctor c++
-Wintrinsic-shadow fortran
-Wintrinsics-std fortran
-Winvalid-offsetof c++ and objc++
@@ -37,7 +39,6 @@
-Wlarger-than=<number> FIXME: choose something sane?
-Wline-truncation fortran
-Wliteral-suffix c++ and objc++
--Wliteral-suffix c++ and objc++
-Wlong-long obsolescent
-Wnoexcept c++
-Wnon-template-friend c++
@@ -45,17 +46,14 @@
-Wnormalized=<id|nfc|nfkc> FIXME: choose something sane?
-Wold-style-cast c++ and objc++
-Woverloaded-virtual c++
--Wpadded FIXME: dunno
--Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
+-Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
-Wpedantic FIXME: too strict?
-Wpmf-conversions c++ and objc++
-Wproperty-assign-default objc++
-Wprotocol objc++
-Wreal-q-constant fortran
-Wrealloc-lhs fortran
--Wrealloc-lhs fortran
-Wrealloc-lhs-all fortran
--Wrealloc-lhs-all fortran
-Wredundant-decls FIXME maybe? many _gl_cxxalias_dummy FPs
-Wreorder c++ and objc++
-Wselector objc and objc++
@@ -71,15 +69,16 @@
-Wswitch-enum FIXME maybe? borderline. some will want this
-Wsynth deprecated
-Wtabs fortran
--Wtarget-lifetime fortran
+-Wtarget-lifetime fortran
-Wtraditional obsolescent
-Wtraditional-conversion obsolescent
-Wundeclared-selector objc and objc++
-Wundef FIXME maybe? too many false positives
-Wunderflow fortran
--Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
+-Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
-Wunused-dummy-argument fortran
-Wuseless-cast c++ and objc++
--Wuseless-cast c++ and objc++
+-Wvirtual-move-assign c++
-Wzero-as-null-pointer-constant c++ and objc++
+-Wzerotrip fortran
-frequire-return-statement go