summaryrefslogtreecommitdiff
path: root/build-aux/gcc-warning.spec
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-11-30 14:25:35 +0100
committerJim Meyering <meyering@redhat.com>2012-09-02 11:01:32 +0200
commitdd44da552f3f158a55b04fbe11ef1d0faf5ee5ba (patch)
tree832d356e844df814315105808496186eac9f632f /build-aux/gcc-warning.spec
parent1af55d85d9762a679b4302d5995f05ccd883e956 (diff)
downloadgnulib-dd44da552f3f158a55b04fbe11ef1d0faf5ee5ba.tar.gz
manywarnings: update the list of "all" warnings
* m4/manywarnings.m4: Unite lists, and add many new options. * build-aux/gcc-warning: New file. Run this command with the latest gcc to see if they have added options not yet on our list: gl=.; comm -1 -3 \ <(sed -n 's/^ *\(-[^ ]*\) .*/\1/p' $gl/m4/manywarnings.m4 |sort) \ <(gcc --help=warnings|sed -n 's/^ \(-[^ ]*\) .*/\1/p' |sort \ |grep -v --line-regexp -f <(cut -f1 $gl/build-aux/gcc-warning.spec))
Diffstat (limited to 'build-aux/gcc-warning.spec')
-rw-r--r--build-aux/gcc-warning.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/build-aux/gcc-warning.spec b/build-aux/gcc-warning.spec
new file mode 100644
index 0000000000..74c6503b9b
--- /dev/null
+++ b/build-aux/gcc-warning.spec
@@ -0,0 +1,85 @@
+# options to filter out, and why
+--all-warnings alias for -Wall
+--extra-warnings alias for -Wextra
+-Waggregate-return obsolescent
+-Waliasing fortran
+-Walign-commons fortran
+-Wampersand fortran
+-Warray-temporaries fortran
+-Wassign-intercept objc/objc++
+-Wc++-compat FIXME maybe? borderline. some will want this
+-Wc++0x-compat c++
+-Wc++11-compat c++
+-Wc-binding-type fortran
+-Wc-binding-type fortran
+-Wcast-qual FIXME maybe? too much noise; encourages bad changes
+-Wcharacter-truncation fortran
+-Wcompare-reals fortran
+-Wconversion FIXME maybe? too much noise; encourages bad changes
+-Wconversion-extra fortran
+-Wconversion-null c++ and objc++
+-Wctor-dtor-privacy c++
+-Wdeclaration-after-statement FIXME: do not want. others may
+-Wdeclaration-after-statement obsolescent
+-Wdelete-non-virtual-dtor c++
+-Weffc++ c++
+-Werror-implicit-function-declaration deprecated
+-Wfloat-equal FIXME maybe? borderline. some will want this
+-Wformat covered by -Wformat=2
+-Wformat= gcc --help=warnings artifact
+-Wfunction-elimination fortran
+-Wimplicit-interface fortran
+-Wimplicit-procedure fortran
+-Wintrinsic-shadow fortran
+-Wintrinsics-std fortran
+-Winvalid-offsetof c++ and objc++
+-Wlarger-than- gcc --help=warnings artifact
+-Wlarger-than=<number> FIXME: choose something sane?
+-Wline-truncation fortran
+-Wliteral-suffix c++ and objc++
+-Wliteral-suffix c++ and objc++
+-Wlong-long obsolescent
+-Wnoexcept c++
+-Wnon-template-friend c++
+-Wnon-virtual-dtor c++
+-Wnormalized=<id|nfc|nfkc> FIXME: choose something sane?
+-Wold-style-cast c++ and objc++
+-Woverloaded-virtual c++
+-Wpadded FIXME: dunno
+-Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
+-Wpedantic FIXME: too strict?
+-Wpmf-conversions c++ and objc++
+-Wproperty-assign-default objc++
+-Wprotocol objc++
+-Wreal-q-constant fortran
+-Wrealloc-lhs fortran
+-Wrealloc-lhs fortran
+-Wrealloc-lhs-all fortran
+-Wrealloc-lhs-all fortran
+-Wredundant-decls FIXME maybe? many _gl_cxxalias_dummy FPs
+-Wreorder c++ and objc++
+-Wselector objc and objc++
+-Wsign-compare FIXME maybe? borderline. some will want this
+-Wsign-conversion FIXME maybe? borderline. some will want this
+-Wsign-promo c++ and objc++
+-Wstack-usage= FIXME: choose something sane?
+-Wstrict-aliasing= FIXME: choose something sane?
+-Wstrict-null-sentinel c++ and objc++
+-Wstrict-overflow= FIXME: choose something sane?
+-Wstrict-selector-match objc and objc++
+-Wsurprising fortran
+-Wswitch-enum FIXME maybe? borderline. some will want this
+-Wsynth deprecated
+-Wtabs fortran
+-Wtarget-lifetime fortran
+-Wtraditional obsolescent
+-Wtraditional-conversion obsolescent
+-Wundeclared-selector objc and objc++
+-Wundef FIXME maybe? too many false positives
+-Wunderflow fortran
+-Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
+-Wunused-dummy-argument fortran
+-Wuseless-cast c++ and objc++
+-Wuseless-cast c++ and objc++
+-Wzero-as-null-pointer-constant c++ and objc++
+-frequire-return-statement go