summaryrefslogtreecommitdiff
path: root/build-aux/gcc-warning.spec
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2015-04-24 12:58:46 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2015-04-24 13:00:18 -0700
commitdf82ac05f6f308ccf07a456242dae34500ea9b9b (patch)
treec7510a87ac7ad97a22155e52f822d876ff25e0ac /build-aux/gcc-warning.spec
parent74fa2c04716bf1fab8b02771cb8a16ac52eb3f72 (diff)
downloadgnulib-df82ac05f6f308ccf07a456242dae34500ea9b9b.tar.gz
manywarnings: add GCC 5.1 warnings
* build-aux/gcc-warning.spec: Add -Wabi=, -Warray-bounds, -Warray-bounds=, -Wc++14-compat, -Wc90-c99-compat, -Wc99-c11-compat, -Wshadow-ivar, -Wsized-deallocation, -Wsuggest-override, -Wuse-without-only. Change -Wnormalized=... operands to match 5.1. * m4/manywarnings.m4 (gl_MANYWARN_ALL_GCC): Add -Wbool-compare, -Wchkp, -Wdesignated-init, -Wdiscarded-array-qualifiers, -Wdiscarded-qualifiers, -Wformat-signedness, -Wincompatible-pointer-types, -Wint-conversion, -Wlogical-not-parentheses, -Wmemset-transposed-args, -Wodr, -Wshift-count-negative, -Wshift-count-overflow, -Wsizeof-array-argument, -Wsuggest-final-methods, -Wsuggest-final-types, -Wswitch-bool. Remove -Warray-bounds, and add -Warray-bounds=2 as a special case.
Diffstat (limited to 'build-aux/gcc-warning.spec')
-rw-r--r--build-aux/gcc-warning.spec12
1 files changed, 11 insertions, 1 deletions
diff --git a/build-aux/gcc-warning.spec b/build-aux/gcc-warning.spec
index 1c250dcb46..4a8c8f5ff0 100644
--- a/build-aux/gcc-warning.spec
+++ b/build-aux/gcc-warning.spec
@@ -2,16 +2,22 @@
--all-warnings alias for -Wall
--extra-warnings alias for -Wextra
-Wabi-tag c++
+-Wabi= c++
-Waggregate-return obsolescent
-Waliasing fortran
-Walign-commons fortran
-Wampersand fortran
+-Warray-bounds covered by -Warray-bounds=
+-Warray-bounds= handled specially by gl_MANYWARN_ALL_GCC
-Warray-temporaries fortran
-Wassign-intercept objc/objc++
-Wc++-compat FIXME maybe? borderline. some will want this
-Wc++0x-compat c++
-Wc++11-compat c++
+-Wc++14-compat c++
-Wc-binding-type fortran
+-Wc90-c99-compat c compatibility
+-Wc99-c11-compat c compatibility
-Wcast-qual FIXME maybe? too much noise; encourages bad changes
-Wcharacter-truncation fortran
-Wcompare-reals fortran
@@ -43,7 +49,7 @@
-Wnoexcept c++
-Wnon-template-friend c++
-Wnon-virtual-dtor c++
--Wnormalized=<id|nfc|nfkc> FIXME: choose something sane?
+-Wnormalized=<none|id|nfc|nfkc> handled specially by gl_MANYWARN_ALL_GCC
-Wold-style-cast c++ and objc++
-Woverloaded-virtual c++
-Wpadded FIXME maybe? warns about "stabil" member in /usr/include/bits/timex.h
@@ -57,14 +63,17 @@
-Wredundant-decls FIXME maybe? many _gl_cxxalias_dummy FPs
-Wreorder c++ and objc++
-Wselector objc and objc++
+-Wshadow-ivar objc
-Wsign-compare FIXME maybe? borderline. some will want this
-Wsign-conversion FIXME maybe? borderline. some will want this
-Wsign-promo c++ and objc++
+-Wsized-deallocation c++ and objc++
-Wstack-usage= FIXME: choose something sane?
-Wstrict-aliasing= FIXME: choose something sane?
-Wstrict-null-sentinel c++ and objc++
-Wstrict-overflow= FIXME: choose something sane?
-Wstrict-selector-match objc and objc++
+-Wsuggest-override c++ and objc++
-Wsurprising fortran
-Wswitch-enum FIXME maybe? borderline. some will want this
-Wsynth deprecated
@@ -77,6 +86,7 @@
-Wunderflow fortran
-Wunsuffixed-float-constants triggers warning in gnulib's timespec.h
-Wunused-dummy-argument fortran
+-Wuse-without-only fortran
-Wuseless-cast c++ and objc++
-Wvirtual-move-assign c++
-Wzero-as-null-pointer-constant c++ and objc++