summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-12-13 14:14:47 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2017-02-22 10:23:25 +0100
commit456c98dc03a80e20e54bc7f185b129b00d792acb (patch)
tree1f943bc18539f970b339824d44bccd21f78e9810
parent5b42ce9c4e39a436d0129f3a6ef9ff47a4a8e1ac (diff)
downloadgnutls-tmp-change-buildroot-to-f25.tar.gz
.gitlab-ci.yml: added compilation of selected fedora components in CItmp-change-buildroot-to-f25
This allows to catch early regressions due to changes.
-rw-r--r--.gitlab-ci.yml43
1 files changed, 43 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 045f954af9..88e200383a 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -2,6 +2,7 @@ stages:
- initialization
- stage1-testing
- stage2-testing
+ - apps-testing
# we utilize the images generated by the build-images project, to
# speed up CI runs.
@@ -496,3 +497,45 @@ build/Debian/x86_64:
- build/*.log
- build/tests/*.log
- build/tests/*/*.log
+
+Fedora/apps/libvirt:
+ stage: apps-testing
+ image: $CI_REGISTRY/$BUILD_IMAGES_PROJECT:$FEDORA_BUILD
+ script:
+ - dnf install -y 'dnf-command(builddep)' fedpkg
+ - make -C lib install && ldconfig &&
+ fedpkg clone -a libvirt -b f25
+ - dnf builddep -y --spec libvirt/libvirt.spec
+ - fedpkg --path libvirt local --builddir ./results
+ tags:
+ - shared
+ dependencies:
+ - ABI-check/Fedora/x86_64
+ except:
+ - tags
+ artifacts:
+ expire_in: 1 week
+ when: on_failure
+ paths:
+ - libvirt/results
+
+Fedora/apps/ocserv:
+ stage: apps-testing
+ image: $CI_REGISTRY/$BUILD_IMAGES_PROJECT:$FEDORA_BUILD
+ script:
+ - dnf install -y 'dnf-command(builddep)' fedpkg
+ - make -C lib install && ldconfig &&
+ fedpkg clone -a ocserv -b f25
+ - dnf builddep -y --spec ocserv/ocserv.spec
+ - fedpkg --path ocserv local --builddir ./results
+ tags:
+ - shared
+ dependencies:
+ - ABI-check/Fedora/x86_64
+ except:
+ - tags
+ artifacts:
+ expire_in: 1 week
+ when: on_failure
+ paths:
+ - ocserv/results