summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2021-05-29 07:41:46 +0000
committerDaiki Ueno <ueno@gnu.org>2021-05-29 07:41:46 +0000
commit1b83d881938b4e37d2bb6475ade716b22364b6cb (patch)
treed2148eed88b92623e5fbce761ebe908834f5bdb0 /Makefile.am
parenta9c7040a1c18b30d1c6e9616b63a7ae100e6a2ec (diff)
parent090c92848190f845a1cff96e159dd7c4b630d6ba (diff)
downloadgnutls-3.7.2.tar.gz
Merge branch 'wip/dueno/release-3.7.2' into 'master'3.7.2
Release 3.7.2 See merge request gnutls/gnutls!1445
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ae5820c62d..80cb64a113 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,15 +60,17 @@ endif
ACLOCAL_AMFLAGS = -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4 --install
EXTRA_DIST = cfg.mk maint.mk CONTRIBUTING.md README.md LICENSE AUTHORS NEWS \
- ChangeLog THANKS INSTALL.md RELEASES.md
+ ChangeLog THANKS INSTALL.md RELEASES.md .mailmap
DISTCLEANFILES = AUTHORS
-AUTHORS:
- @echo -e "The authors list is autogenerated from the git history; sorted by number of commits\n" >AUTHORS
- @git shortlog -sen| cut -f 2 | sed 's/@/ at /g' >> AUTHORS
- @echo -e "\n\nThe translators list is autogenerated from po file history\n" >>AUTHORS
- @sed -n 's/.*Last-Translator: *\(.*\) *<.*/\1/p' po/*.po | sort -u >>AUTHORS
+AUTHORS: Makefile.am .mailmap
+ $(AM_V_GEN) { \
+ echo -e "The authors list is autogenerated from the git history; sorted by number of commits\n"; \
+ git shortlog -sen --no-merges --group author --group trailer:co-authored-by | cut -f 2 | sed 's/@/ at /g'; \
+ echo -e "\n\nThe translators list is autogenerated from po file history\n"; \
+ sed -n 's/.*Last-Translator: *\(.*\) *<.*/\1/p' po/*.po | sort -u; \
+ } > $@-t && mv $@-t $@
pic-check:
@echo "Checking for position dependent code"