summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-29 18:04:50 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-29 18:06:21 +0200
commit754a98026825b6c3cf8022266f84aeebf57bda8d (patch)
tree015a3c504bcf3c5a45040f648d0627ea603f5286 /Makefile.am
parent9424a727ab3a720103b3ab6161a9351ae8d40743 (diff)
downloadgnutls-754a98026825b6c3cf8022266f84aeebf57bda8d.tar.gz
.gitlab-ci.yml: added code coverage run
This enhances a test to print the code coverage of the test suite, which in turn is being used/reported by gitlab CI interface.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5564c9189d..4f561e3766 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,9 @@ abi-check:
@CODE_COVERAGE_RULES@
+local-code-coverage-output: code-coverage-capture
+ cat GnuTLS-$(VERSION)-coverage/index.html|grep headerCovTableEntryLo|head -1|sed 's/^.*>\([0-9]\+\.[0-9]\+\s*%\)<.*$$/ coverage lines: \1/'
+
dist-hook: abi-check
make -C doc/ compare-makefile
make -C doc/ compare-exported