summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2022-01-15 14:33:53 +0000
committerDaiki Ueno <ueno@gnu.org>2022-01-15 14:33:53 +0000
commit6000b2d93b6cb9acd45adc9b4d8f7bf2f1cb49b2 (patch)
treea6d1a0c34a61ac0a3aa2e3620793a75c2c2f9098 /configure.ac
parent6fa472075e7b8e4fb51d089eaee4ed2094e7335b (diff)
parent0bce0cbdf20a13fc8c063e5941ba0187d6d4c8f1 (diff)
downloadgnutls-6000b2d93b6cb9acd45adc9b4d8f7bf2f1cb49b2.tar.gz
Merge branch 'wip/dueno/remove-autogen' into 'master'
remove autogen dependency Closes #775, #774, and #773 See merge request gnutls/gnutls!1506
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 3 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 667e07fdc2..26c890e2c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,7 +25,7 @@ AC_PREREQ(2.64)
dnl when updating version also update LT_REVISION in m4/hooks.m4
AC_INIT([GnuTLS], [3.7.2], [bugs@gnutls.org])
AC_CONFIG_AUX_DIR([build-aux])
-AC_CONFIG_MACRO_DIRS([m4 src/gl/m4 src/libopts/m4 lib/unistring/m4])
+AC_CONFIG_MACRO_DIRS([m4 src/gl/m4 lib/unistring/m4])
AC_CANONICAL_HOST
AM_INIT_AUTOMAKE([1.12.2 foreign subdir-objects no-dist-gzip dist-xz -Wall -Wno-override])
@@ -486,7 +486,7 @@ fi
AM_CONDITIONAL(WANT_TEST_SUITE, test "$full_test_suite" = "yes")
# parts of the extended test suite use Python
-AM_PATH_PYTHON(,, [:])
+AM_PATH_PYTHON([3.6],, [:])
AC_ARG_ENABLE(oldgnutls-interop,
AS_HELP_STRING([--enable-oldgnutls-interop], [enable interoperability testing with old gnutls version]),
@@ -936,33 +936,6 @@ fi
AC_DEFINE_UNQUOTED([TROUSERS_LIB], ["$ac_trousers_lib"], [the location of the trousers library])
AC_SUBST(TROUSERS_LIB)
-AM_MISSING_PROG([AUTOGEN], [autogen])
-
-included_libopts=no
-if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
- AC_CHECK_PROGS([autogen], [autogen])
-
- if test -z "$autogen"; then
- AC_MSG_WARN([[
-***
-*** autogen not found. Will not link against system libopts.
-*** ]])
- dnl simulate specifying option on the command line
- included_libopts=yes
- fi
- LIBOPTS_CHECK([src/libopts])
- if test "$NEED_LIBOPTS_DIR" = "true";then
- dnl replace libopts-generated files with distributed backups, if present
- included_libopts=yes
- fi
-else
- # Need to ensure the relevant conditionals get set
- gl_STDNORETURN_H
- AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
-fi
-
-AM_CONDITIONAL(NEED_LIBOPTS, test "$included_libopts" = "yes")
-
# For minitasn1.
AC_CHECK_SIZEOF(unsigned long int, 4)
AC_CHECK_SIZEOF(unsigned int, 4)
@@ -1215,7 +1188,6 @@ AC_CONFIG_FILES([
lib/unistring/Makefile
po/Makefile.in
src/Makefile
- src/args-std.def
src/gl/Makefile
src/gl/tests/Makefile
tests/Makefile
@@ -1224,6 +1196,7 @@ AC_CONFIG_FILES([
tests/slow/Makefile
tests/suite/Makefile
fuzz/Makefile
+ python/Makefile
])
AC_OUTPUT
@@ -1239,7 +1212,6 @@ AC_MSG_NOTICE([summary of build options:
Valgrind: $opt_valgrind_tests ${VALGRIND}
CFlags: ${CFLAGS}
Library types: Shared=${enable_shared}, Static=${enable_static}
- Local libopts: ${included_libopts}
Local libtasn1: ${included_libtasn1}
Local unistring: ${included_unistring}
Use nettle-mini: ${mini_nettle}