summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHedgehog5040 <krenzelok.frantisek@gmail.com>2021-05-14 15:56:06 +0200
committerFrantisek Krenzelok <krenzelok.frantisek@gmail.com>2021-10-19 15:17:45 +0200
commit6462916d2f6810409d5da1e13c4a0720f412c166 (patch)
tree0a99301f57c2dd8d2b477b15cd068378751e9be9 /configure.ac
parent17f76888e27c822776166636e28c492d1f0a60ed (diff)
downloadgnutls-6462916d2f6810409d5da1e13c4a0720f412c166.tar.gz
ktls: basic implementation of SW mode
ktls enables us to offload encryption/decryption to the kernel prerequisites: - configured with `--enable-ktls` - tls module `modprobe tls` check with 'lsmod | grep tls' - per connection: gnutls_transport_set_int{2} must be set When prerequisities are met then ktls is used by default. If GnuTLS encounters a error during KTLS initialization, it will not use ktls and fallback to userspace. Signed-off-by: Frantisek Krenzelok <krenzelok.frantisek@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10b25e216d..c22acef7c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1220,6 +1220,7 @@ AC_MSG_NOTICE([External hardware support:
Random gen. variant: $rnd_variant
PKCS#11 support: $with_p11_kit
TPM support: $with_tpm
+ KTLS support: $enable_ktls
])
if test -n "$ac_trousers_lib";then
AC_MSG_NOTICE([