summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarvin Scholz <epirat07@gmail.com>2022-02-23 19:03:51 +0100
committerMarvin Scholz <epirat07@gmail.com>2022-02-23 19:05:19 +0100
commitc19cb93d492e45141bfef9b926dfeba36003261c (patch)
tree79e450ea0f74456ade7d6efad0314cb6b5864b0d /configure.ac
parent94077fa2993a3400b18229dae6eb816ede53f253 (diff)
downloadgnutls-c19cb93d492e45141bfef9b926dfeba36003261c.tar.gz
configure.ac: add missing Libs.private for macOS
On macOS the CoreFoundation and Security frameworks are used by GnuTLS, however those were missing in the Libs.private in the .pc resulting in link failures with static builds when relying on the output of pkg-config --static. Signed-off-by: Marvin Scholz <epirat07@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53c3aefca1..9378d81f10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,7 @@ case "$host" in
AC_MSG_CHECKING([whether the linker supports -Wl,-no_weak_imports])
AC_LINK_IFELSE([AC_LANG_PROGRAM([], [])],
[AC_MSG_RESULT(yes)], [AC_MSG_RESULT(no); LDFLAGS="$save_LDFLAGS"])
+ GNUTLS_LIBS_PRIVATE="${GNUTLS_LIBS_PRIVATE} -framework Security -framework CoreFoundation"
;;
*solaris*)
have_elf=yes