summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZoltan Fridrich <zfridric@redhat.com>2022-03-08 18:01:37 +0100
committerZoltan Fridrich <zfridric@redhat.com>2022-03-16 09:38:00 +0100
commitfeec08cec6caa9da4d2353a7fe0d68f0e49da8ca (patch)
tree860f4bdf3d48e34e3f40eb3bf54c31ef2d1048ab /configure.ac
parentcfeb73a460a56f49ea95c45ec501c2f5f8a5d32f (diff)
downloadgnutls-feec08cec6caa9da4d2353a7fe0d68f0e49da8ca.tar.gz
Make gnutls compliant to RFC5280
Signed-off-by: Zoltan Fridrich <zfridric@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 351cf4593e..894b301047 100644
--- a/configure.ac
+++ b/configure.ac
@@ -622,6 +622,13 @@ if [ test "$enable_fips" = "yes" ];then
fi
fi
+AC_ARG_ENABLE(strict-x509,
+ AS_HELP_STRING([--enable-strict-x509], [enable stricter sanity checks for x509 certificates]),
+ enable_strict_x509=$enableval, enable_strict_x509=no)
+if test "$enable_strict_x509" != "no"; then
+ AC_DEFINE([STRICT_X509], 1, [Enable stricter sanity checks for x509 certificates])
+fi
+
AC_ARG_WITH([pkcs12-iter-count],
[AS_HELP_STRING([--with-pkcs12-iter-count],
[specify iteration count for PKCS\#12 key derivation @<:@default=600000@:>@])],