summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2022-10-12 15:02:35 +0200
committerSimon Josefsson <simon@josefsson.org>2022-10-26 13:03:35 +0200
commit100cc2a706b8e097cbeb63d08c7ea59717c906ca (patch)
tree914c59fcb47a35d67ee209b0b9d38e2f3cbaa3b6 /doc/Makefile.am
parent8610f63f5a757b6f688bf44cb4c52609f48fdb5e (diff)
downloadgnutls-100cc2a706b8e097cbeb63d08c7ea59717c906ca.tar.gz
Drop guile bindings. See <https://gitlab.com/gnutls/guile/>.
Signed-off-by: Simon Josefsson <simon@josefsson.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am38
1 files changed, 2 insertions, 36 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3a4151036c..e3e48c8903 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -21,7 +21,7 @@
EXTRA_DIST = TODO certtool.cfg gnutls.html \
doxygen/Doxyfile.in doxygen/Doxyfile.orig texinfo.css \
- gnutls-guile.html stamp_enums stamp_functions \
+ stamp_enums stamp_functions \
doc.mk COPYING COPYING.LESSER
IMAGES = \
@@ -175,7 +175,7 @@ invoke-tpmtool.texi: $(top_srcdir)/src/tpmtool-options.json
$< $@
-info_TEXINFOS = gnutls.texi gnutls-guile.texi
+info_TEXINFOS = gnutls.texi
gnutls_TEXINFOS = gnutls.texi fdl-1.3.texi \
cha-bib.texi cha-cert-auth.texi cha-cert-auth2.texi \
cha-ciphersuites.texi cha-copying.texi cha-functions.texi \
@@ -511,40 +511,6 @@ compare-makefile: enums.texi
.PHONY: compare-makefile compare-exported
-# Guile texinfos.
-
-guile_texi = core.c.texi
-BUILT_SOURCES = $(guile_texi)
-MAINTAINERCLEANFILES += $(guile_texi)
-EXTRA_DIST += $(guile_texi) extract-guile-c-doc.scm
-guile_TEXINFOS = gnutls-guile.texi $(guile_texi)
-
-if HAVE_GUILE
-
-GUILE_FOR_BUILD = \
- GUILE_AUTO_COMPILE=0 \
- $(GUILE) -q -L $(top_srcdir)/guile/modules
-
-SNARF_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir) \
- -I$(top_srcdir)/lib/includes -I$(top_builddir)/lib/includes \
- -I$(top_srcdir)/extra/includes \
- -I$(top_srcdir)/guile/src -I$(top_builddir)/guile/src \
- $(GUILE_CFLAGS)
-
-core.c.texi: $(top_srcdir)/guile/src/core.c
- $(MAKE) -C ../guile/src built-sources && \
- $(GUILE_FOR_BUILD) -l "$(srcdir)/extract-guile-c-doc.scm" \
- -e '(apply main (cdr (command-line)))' \
- -- "$^" "$(CPP)" "$(SNARF_CPPFLAGS) $(CPPFLAGS)" \
- > "$@"
-
-else !HAVE_GUILE
-
-core.c.texi:
- echo "(Guile not available, documentation not generated.)" > $@
-
-endif !HAVE_GUILE
-
gnutls.xml: epub.texi
makeinfo --docbook $<
$(SED) -i 's/\&\#8226;//g' $@