summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2022-01-15 11:27:20 +0100
committerDaiki Ueno <ueno@gnu.org>2022-05-05 16:50:04 +0200
commit26d57fdad875962400cb117f257a38ad0781ea3a (patch)
treef0439343711c7959338c26d58fc64e0c97ee8892 /doc/Makefile.am
parentb70b1838a22ebf901e4d926021a5c33732797864 (diff)
downloadgnutls-26d57fdad875962400cb117f257a38ad0781ea3a.tar.gz
gnutls_aead_cipher_set_key: new function
This adds gnutls_aead_cipher_set_key, which enables to reuse the same handle but reset the context and key, without releasing the memory. Signed-off-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 59472b1a3f..d20a021d97 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -680,6 +680,8 @@ FUNCS += functions/gnutls_aead_cipher_encryptv2
FUNCS += functions/gnutls_aead_cipher_encryptv2.short
FUNCS += functions/gnutls_aead_cipher_init
FUNCS += functions/gnutls_aead_cipher_init.short
+FUNCS += functions/gnutls_aead_cipher_set_key
+FUNCS += functions/gnutls_aead_cipher_set_key.short
FUNCS += functions/gnutls_alert_get
FUNCS += functions/gnutls_alert_get.short
FUNCS += functions/gnutls_alert_get_name