summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-25 17:08:43 +0200
committerDaiki Ueno <dueno@redhat.com>2019-05-14 06:44:38 +0200
commit2dc96e3b8d0e043bebf0815edaaa945f66ac0531 (patch)
treedf3932ecaf592291b53cb8936d23ba19f9226f50 /doc/Makefile.am
parent9509af0e791b74538de8ffa8dd0d47c05cb08eed (diff)
downloadgnutls-2dc96e3b8d0e043bebf0815edaaa945f66ac0531.tar.gz
ext/record_size_limit: distinguish sending and receiving limitstmp-record-sizes
The previous behavior was that both sending and receiving limits are negotiated to be the same value. It was problematic when: - client sends a record_size_limit with a large value in CH - server sends a record_size_limit with a smaller value in EE - client updates the limit for both sending and receiving, upon receiving EE - server sends a Certificate message larger than the limit With this patch, each peer maintains the sending / receiving limits separately so not to confuse with the contradicting settings. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index c60d0e46dd..bba2c52c97 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1851,6 +1851,8 @@ FUNCS += functions/gnutls_record_send_range
FUNCS += functions/gnutls_record_send_range.short
FUNCS += functions/gnutls_record_set_max_early_data_size
FUNCS += functions/gnutls_record_set_max_early_data_size.short
+FUNCS += functions/gnutls_record_set_max_recv_size
+FUNCS += functions/gnutls_record_set_max_recv_size.short
FUNCS += functions/gnutls_record_set_max_size
FUNCS += functions/gnutls_record_set_max_size.short
FUNCS += functions/gnutls_record_set_state