summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-04-11 12:11:00 +0200
committerDaiki Ueno <dueno@redhat.com>2019-04-19 08:56:51 +0200
commit89c975cc25d4e7c5040a3f657b732dd1704bfb2b (patch)
tree223c8d24d1e790c2fdfc0fd1ff090be16bd087d5 /doc/Makefile.am
parent0e579649a6e9ab690f0a3f6f8a0b7abd3f715881 (diff)
downloadgnutls-89c975cc25d4e7c5040a3f657b732dd1704bfb2b.tar.gz
prf: add function to retrieve early keying material
This adds a new function gnutls_prf_early, which shall be called in a handshake hook waiting for GNUTLS_HANDSHAKE_CLIENT_HELLO. The test needs to be run in a datefudge wrapper as the early secrets depend on the current time (through PSK). Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 19982f5ad8..c60d0e46dd 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1547,6 +1547,8 @@ FUNCS += functions/gnutls_pk_to_sign
FUNCS += functions/gnutls_pk_to_sign.short
FUNCS += functions/gnutls_prf
FUNCS += functions/gnutls_prf.short
+FUNCS += functions/gnutls_prf_early
+FUNCS += functions/gnutls_prf_early.short
FUNCS += functions/gnutls_prf_raw
FUNCS += functions/gnutls_prf_raw.short
FUNCS += functions/gnutls_prf_rfc5705