summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-08-02 07:40:44 +0200
committerDaiki Ueno <dueno@redhat.com>2019-08-09 13:11:22 +0200
commitd230011cdbbe55f429b43d818c75c8f6687cbc78 (patch)
treeee01995396ce288a37f3323656a54ae6fecba35d /doc/Makefile.am
parent9ca7a2b42168d356126e306e25211d43ea3c2e7d (diff)
downloadgnutls-d230011cdbbe55f429b43d818c75c8f6687cbc78.tar.gz
crypto-api: add gnutls_aead_cipher_{en,de}cryptv2tmp-encryptv2
This adds an in-place equivalent of gnutls_aead_cipher_encrypt() and gnutls_aead_cipher_decrypt(), that works on data buffers. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 6d21d74820..add63c23d5 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -635,12 +635,16 @@ FUNCS += functions/dane_verify_session_crt
FUNCS += functions/dane_verify_session_crt.short
FUNCS += functions/gnutls_aead_cipher_decrypt
FUNCS += functions/gnutls_aead_cipher_decrypt.short
+FUNCS += functions/gnutls_aead_cipher_decryptv2
+FUNCS += functions/gnutls_aead_cipher_decryptv2.short
FUNCS += functions/gnutls_aead_cipher_deinit
FUNCS += functions/gnutls_aead_cipher_deinit.short
FUNCS += functions/gnutls_aead_cipher_encrypt
FUNCS += functions/gnutls_aead_cipher_encrypt.short
FUNCS += functions/gnutls_aead_cipher_encryptv
FUNCS += functions/gnutls_aead_cipher_encryptv.short
+FUNCS += functions/gnutls_aead_cipher_encryptv2
+FUNCS += functions/gnutls_aead_cipher_encryptv2.short
FUNCS += functions/gnutls_aead_cipher_init
FUNCS += functions/gnutls_aead_cipher_init.short
FUNCS += functions/gnutls_alert_get