summaryrefslogtreecommitdiff
path: root/doc/manpages/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2023-05-02 08:41:08 +0900
committerDaiki Ueno <ueno@gnu.org>2023-05-04 18:47:56 +0900
commit4fe788cc172e6c06f40a42ba516a60f21369018c (patch)
tree1e84b4e61a611894f264ceb5e9e2ef9a51dacfd0 /doc/manpages/Makefile.am
parent643342325a15e652fedac27b7bcb4614a242ab0d (diff)
downloadgnutls-4fe788cc172e6c06f40a42ba516a60f21369018c.tar.gz
psk: Add basic support for RFC 9258 external PSK importer interface
This adds a minimal, callback-based API to import external PSK, following RFC 9258. The client and the server importing external PSK are supposed to set a callback to retrieve PSK, which returns flags that may indicate the PSK is imported, along with the key: typedef int gnutls_psk_client_credentials_function3( gnutls_session_t session, gnutls_datum_t *username, gnutls_datum_t *key, gnutls_psk_key_flags *flags); typedef int gnutls_psk_server_credentials_function3( gnutls_session_t session, const gnutls_datum_t *username, gnutls_datum_t *key, gnutls_psk_key_flags *flags); Those callbacks are responsible to call gnutls_psk_format_imported_identity() for external PSKs to build a serialized PSK identity, and set GNUTLS_PSK_KEY_EXT in flags if the identity is an imported one. Signed-off-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'doc/manpages/Makefile.am')
-rw-r--r--doc/manpages/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/doc/manpages/Makefile.am b/doc/manpages/Makefile.am
index 27cf77a57e..24ca59888f 100644
--- a/doc/manpages/Makefile.am
+++ b/doc/manpages/Makefile.am
@@ -732,6 +732,7 @@ APIMANS += gnutls_protocol_set_enabled.3
APIMANS += gnutls_psk_allocate_client_credentials.3
APIMANS += gnutls_psk_allocate_server_credentials.3
APIMANS += gnutls_psk_client_get_hint.3
+APIMANS += gnutls_psk_format_imported_identity.3
APIMANS += gnutls_psk_free_client_credentials.3
APIMANS += gnutls_psk_free_server_credentials.3
APIMANS += gnutls_psk_server_get_username.3
@@ -740,10 +741,12 @@ APIMANS += gnutls_psk_set_client_credentials.3
APIMANS += gnutls_psk_set_client_credentials2.3
APIMANS += gnutls_psk_set_client_credentials_function.3
APIMANS += gnutls_psk_set_client_credentials_function2.3
+APIMANS += gnutls_psk_set_client_credentials_function3.3
APIMANS += gnutls_psk_set_params_function.3
APIMANS += gnutls_psk_set_server_credentials_file.3
APIMANS += gnutls_psk_set_server_credentials_function.3
APIMANS += gnutls_psk_set_server_credentials_function2.3
+APIMANS += gnutls_psk_set_server_credentials_function3.3
APIMANS += gnutls_psk_set_server_credentials_hint.3
APIMANS += gnutls_psk_set_server_dh_params.3
APIMANS += gnutls_psk_set_server_known_dh_params.3