summaryrefslogtreecommitdiff
path: root/fuzz/Makefile.am
diff options
context:
space:
mode:
authorTim Rühsen <tim.ruehsen@gmx.de>2018-06-19 12:02:13 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-06-20 12:06:41 +0000
commit953e343c4cebe9d728f385e89dddb8a05576e279 (patch)
tree9a333f2e86dc3996e173365f2d902f2a56a82d7d /fuzz/Makefile.am
parentd1240a03839f3c1ddd65acea9496622615ee3183 (diff)
downloadgnutls-953e343c4cebe9d728f385e89dddb8a05576e279.tar.gz
Remove oss-fuzz copora from tarball
The size of the corpora is huge and not needed for normal builds. This patch also fixes test run issues on Windows.
Diffstat (limited to 'fuzz/Makefile.am')
-rw-r--r--fuzz/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/fuzz/Makefile.am b/fuzz/Makefile.am
index 9093034aca..3483f0cc81 100644
--- a/fuzz/Makefile.am
+++ b/fuzz/Makefile.am
@@ -57,10 +57,12 @@ gnutls_set_trust_file_fuzzer_LDADD = $(LDADD) $(LIBDL)
#EXTRA_DIST = $(wildcard *.options) $(wildcard *.dict) \
# $(wildcard *.in) $(wildcard *.repro)
+# We don't include the fuzz corpora into the tarball.
+# Testing the corpora during dev cycles and in the CI is enough.
dist-hook:
find . -name '*.options' -exec cp -v '{}' $(distdir) ';'
find . -name '*.dict' -exec cp -v '{}' $(distdir) ';'
- find . -name '*.in' -exec cp -vr '{}' $(distdir) ';'
+# find . -name '*.in' -exec cp -vr '{}' $(distdir) ';'
find . -name '*.repro' -exec cp -vr '{}' $(distdir) ';'
TESTS = $(FUZZERS)