summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2017-09-29 15:16:04 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-02-19 15:29:35 +0100
commit4f81fa3502fa7a1263622b1fe0ba453bc6e86552 (patch)
tree6a615b84fc868ab4945aa46ee217ad9767d3972e /lib/Makefile.am
parentc79f06860a0115c30ccee8ce7ad527b9d0733a6a (diff)
downloadgnutls-4f81fa3502fa7a1263622b1fe0ba453bc6e86552.tar.gz
handshake: added support for reading and sending cookie extension
That introduces an internal API to associate data to an extension. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 81ef76832a..ed229e47ab 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -79,7 +79,8 @@ COBJECTS = range.c record.c compress.c debug.c cipher.c gthreads.h handshake-tls
safe-memfuncs.c system/inet_pton.c atfork.c atfork.h randomart.c \
system-keys.h urls.c urls.h prf.c auto-verify.c dh-session.c \
cert-session.c handshake-checks.c dtls-sw.c dh-primes.c openpgp_compat.c \
- crypto-selftests.c crypto-selftests-pk.c secrets.c extv.c extv.h
+ crypto-selftests.c crypto-selftests-pk.c secrets.c extv.c extv.h \
+ hello_ext_lib.c hello_ext_lib.h
if WINDOWS
COBJECTS += system/keys-win.c