summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2008-04-17 13:28:11 +0200
committerSimon Josefsson <simon@josefsson.org>2008-04-17 13:28:11 +0200
commite9112f5bbe78b2d8c772432d8b69294a4dd43624 (patch)
treec03e89dca8070f88580d8f10c1815e414fc29e17 /lib/Makefile.am
parentbadf8ae9e80620e03951cca71f59603fdb3550a8 (diff)
downloadgnutls-e9112f5bbe78b2d8c772432d8b69294a4dd43624.tar.gz
Remove code to link with external opencdk.
It seems we now don't have resources to maintain the LGPL opencdk code externally, since making it use GnuTLS's crypto code will be complicated. See discussion in: http://thread.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/2672/focus=2711
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 21411415e2..843358e7f0 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -37,10 +37,8 @@ AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" \
$(LIBOPENCDK_CFLAGS) $(LIBGCRYPT_CFLAGS)
if ENABLE_OPENPGP
-if ENABLE_INCLUDED_OPENCDK
SUBDIRS += opencdk
AM_CPPFLAGS += -I$(srcdir)/opencdk
-endif
SUBDIRS += openpgp
endif
@@ -122,11 +120,7 @@ libgnutls_la_LIBADD = ../lgl/liblgnu.la x509/libgnutls_x509.la \
if ENABLE_OPENPGP
libgnutls_la_SOURCES += gnutls_openpgp.c
libgnutls_la_LIBADD += openpgp/libgnutls_openpgp.la
-if ENABLE_INCLUDED_OPENCDK
libgnutls_la_LIBADD += opencdk/libminiopencdk.la
-else
-libgnutls_la_LDFLAGS += $(LTLIBOPENCDK)
-endif
endif
if HAVE_LD_VERSION_SCRIPT